Security Advisory
  • Google Chrome Multiple Vulnerabilities Reported Date: 05-07-10
Rated Level: Critical
Impact: System Access,Unknown,Remotely Exploitable
Affected Software: Google Chrome 4.x
Description: Multiple vulnerabilities have been reported in Google Chrome, where some have an unknown impact and others can potentially be exploited by malicious people to compromise a vulnerable system.

1) An unspecified error related to WebGL can be exploited to trigger an OOB read. No further information is currently available.

2) An unspecified error exists related to the isolation of sandboxed iframes. No further information is currently available.

3) An unspecified error in the processing of SVG images can be exploited to corrupt memory.

4) An unspecified error related to the bidi algorithm can be exploited to corrupt memory.

5) An unspecified error in the processing of invalid images can be exploited to cause a crash. No further information is currently available.

6) A vulnerability in the processing of PNG images can be exploited to corrupt memory.

7) An unspecified error in the CSS style rendering can be exploited to corrupt memory.

8) An unspecified error exists related to print dialogs. No further information is currently available.

9) An unspecified error related to modal dialogs can be exploited to cause a crash.


Note: The vendor credits:
1) Sergey Glazunov; Google Chrome Security Team (SkyLined)
2) sirdarckcat, Google Security Team
3) Aki Hekin of OUSPG and wushi of team509
4, 7) wushi of team509
5) Jose A. Vazquez
6, 9) Aki Helin, OUSPG
8) Mats Ahlgren
Solution: Update to version 5.0.375.99.
Feedback: If you have additional information or corrections for this security advisory please contact us at advisory(at)triviasecurity.org

Security Advisories by Month (2014)
TS Promotion